Symptom 1: Error in Date format
I have created a CSV using the Sample file on the LegacyFlo GUI and uploaded the same using Add Multiple Requests.
I have confirmed that the CSV is correct. However the requests are failing with a message that the date in the Since or Before fields is invalid.
Cause
There can be multiple causes as mentioned here
a) The dates in the Since or Before fields HAVE NOT BEEN SPECIFIED in the required DD-MMM-YYYY format. All dates have to be given in this format only. For example 01-Jan-2024.
b) You created the CSV using a spread sheet and when generating the program changed the format.
Solutions
a) If you are using a text editor, make sure that the dates are in the dd-mmm-yyyy format.
b) If you are using a spread-sheet, follow the process as below:
I) Add all the records without mentioning the Since and before Dates
II) Select the Since and Before columns and change the field type to Text as shown in (B) and (C) in the image below.
III) Enter the dates in dd-mmm-yyyy formats.
IV) Save the file
NOTE: If you open an existing CSV for editing, the spreadsheet will again change the format (as shown in A in the image below) and you will have to repeat steps in (b)
Symptom 2: Error in a field: Invalid format
I have created a CSV using the Sample file on the LegacyFlo GUI and uploaded the same using Add Multiple Requests.
I have confirmed that the CSV is correct. However the requests are failing with a message that a field is invalid
Cause
This can happen if the field values contain a leading or trailing space. For example, in the above expample, the field "destS3StorageClass" had a leading space in the value " STANDARD".
Solution
Edit the CSV and remove any leading or trailing spaces in the field. The correct value in the above example should be "STANDARD"
Symptom 3: Error "Invalid Request Type"
I have created a CSV using the Sample file on the LegacyFlo GUI and uploaded the same using Add Multiple Requests.
I have confirmed that the CSV is correct. However the upload is failing with the error "Invalid Request Type"
Cause
There is an empty line in the csv file. A valid CSV file has the header row as the first row and valid records from the second row. There should be no empty lines in the middle or at the end of the file.
If the CSV is generated using MS Excel version 2007 and above, an empty line is added at the end.
Solution
Open the CSV in notepad and delete any empty lines in the CSV, including the empty line at the end.